Homesteadアップデートのエラー対応:sha512

Laravel

Homesteadが古くなったのでアップデートでエラー対応したので、備忘録としてメモを残します。
[公式ドキュメント](https://readouble.com/laravel/5.8/ja/homestead.html)を参考にしてます。

・まずはHomesteadのディレクトリに移動して、最新版をGitからPullします。

git fetch
git pull origin release

・composerパッケージをアップデートします

composer update

・Boxをアップデートしたら完了ですが、Vagrantのバージョンが古いと以下のようなエラーになります。
sha512がサポートされていないようですので、Vagrantをアップデートします。
公式:
https://www.vagrantup.com/downloads.html

vagrant box update

# エラー
The specified checksum type is not supported by Vagrant: sha512.
Vagrant supports the following checksum types:

md5, sha1, sha256

・もう一度、Boxをアップデートします。

vagrant box update

・Boxを起動したら完了です。

vagrant up

コメント